Export

From LibreCAD wiki
Jump to: navigation, search


LibreCAD has the ability to export to a variety of file formats. This can be accomplished by selecting File->Export.

MakerCAM SVG

Lorem ipsum

Instructions

Lorem ipsum

PDF

Note that the options selected in Print Preview define aspects of the PDF output.

PDF Export appears to be generally working as intended. For example, it will print in color or black & white as desired, and the pen widths are the defined size on the exported PDF. That is, a layer defined with a given pen width will export at that pen width, regardless of scale. This can be confirmed by setting pen widths for layers, exporting a PDF, and measuring line widths using an image editing program. GIMP, for example, has that capability, and is free & open source.

Instructions

  1. Confirm through Options->Current Drawing Preferences->Paper that the desired paper size and orientation have been selected.
  2. Confirm through File->Print Preview Pp.png that desired scale, positioning, and black & white/color options have been selected.
  3. Select File->Export->Export as PDF.
  4. Choose location and file name.

Image

"Image" covers a number of raster and vector formats, including SVG.

The image exporting capability does not seem to be working as intended. There appear to be issues defining dimensions and resolution. (See below)

Instructions

  1. Confirm through Options->Current Drawing Preferences->Paper that the desired paper size and orientation have been selected.
  2. Confirm through File->Print Preview Pp.png that desired scale, positioning, and black & white/color options have been selected.
  3. Select File->Export->Export as image
  4. Choose location, file name, and file type.
  5. Choose image export options. (Note that there appear to be issues with both functionality and clarity of the image export options.)

Issues and Workarounds

The intent is not to mirror related Issues in the GitHub repository, but to present workarounds to accomplish specific tasks.

Generate an Image File with Specific Properties

Certain circumstances require the generation of an image file with specific properties. For example, an academic journal may require an image of a schematic to be at least 4" in any one direction, 300 DPI or greater, and TIF format. Knowing that the pen widths will show as intended is also likely to be necessary in such a case. As noted previously, the image exporting capability of LibreCAD alone does not seem to be working as intended for that task.

One successful workaround is to generate the image in PDF format, import it into imaging software (GIMP, as an example again, has the capability and is free & open source), and modify/save as needed.