LibreCAD Brief Overview

From LibreCAD wiki
Jump to: navigation, search

Introduction

This manual is for those people who are too lazy to read through the actual manuals of LibreCAD. It should give a short introduction into LibreCAD. For further reading see further information. If you find some mistakes or find some steps not beeing explained well, you are encouraged to tell this on the forums of LibreCAD. To make clear what you have to type in the input line of the command line, the commands are in quotes. When you use/type the command, leave out the quotes.

Main window

Some important regions of the main window can be seen in the following image.

Mainwind4 1.png


For more detailed information

Drawing

Drawing in LibreCAD can be done in two ways:

  1. drawing with the mouse
  2. drawing with the keyboard

When drawing with the mouse, you just click on one of the icons from the cad/draw-toolbar and click with the left mouse button on the canvas. Undoing the last operation is done by pressing the right mouse button. The right mouse button as well as the Esc key can be used to end the draw procedure. To zoom you can spin the mouse wheel and to drag the canvas just press the mouse wheel and move the mouse. The steps to draw with your keyboard are the same as the steps taken while drawing with the mouse. The difference is, you have to type the commands/instructions into the command line.


Hint.png If you don't know what to do in the next step, when drawing, you may want to have a look at the comment in the command line.


Cadtoolbar.png



These are the options you will use the most when drawing. They allow you to create points, lines, ... .





These are the less used options like adding text, dimensions, images, ...






To modify your drawing, either click on the drawing and move the points or use : “Modify” → “Edit Entity Geometry” or “Modify” → Edit Entity Attributes” Some modify options let you select the entities (lines, circles,...) you want to modify, to leave the selection mode and tell LibreCAD that you selected all you wanted press the Continue action1.png button in the cadtoolbar (!!! one of the most overlooked steps !!!).


Example for drawing a line:

  1. using the mouse
    • "Draw" → "Line" → "2 Points"
    • click where you want the first point to be
    • (as the “draw line process is not finished you can use the right mouse button to reset the first point)
    • click where you want the second point to be
    • if you want to have more points just keep clicking on the places you want them to be
    • as the process of “drawing a line (at least two points)” is done after selecting the second point you can press the right mouse button to end the process or press the Esc key
  2. using the keyboard
    • press Ctrl+M or the Space (or click with the mouse into the input line of the “command line”)
    • type “li” or “line” (to confirm your input you have always to press the enter/return key)
    • to create the first point just type the coordinates of the first point “50,50”
    • to create the second point type “50,60”
    • now you can proceed in different ways like told in “using the mouse”


Hint.png As you may noticed, every time you create a new point, the “relative zero point” () is moved to the position of this point (if the option “Lock relative zero position” is disabled). You can use the relative zero point as the start point for the next point you want to create. To do that you have to type “@” before the coordinates of the next point. So “@60,70” would create a point which is placed 60 units in the x-direction and 70 units in the y-direction (from the position of the relative zero point). If you prefer the polar coordinates for drawing, use “LENGTH<ANGLEINDEGREE” to draw a line. Typing “30<45” will create a 30 units long line with an angle of 45° (from the absolute zero point). The “@” sign can be used here the same way. If you like to use weird unit you can use "line 1'10"<45 @60'4"<50" to draw a line. If you like to use weird unit you can use line 1'10"<45 @60'4"<50 to draw a line.

Printing

If you want your drawing to be fitted on the page automatically and though don't mind in what aspect ratio it is printed, you can just hit the print button.


Hint.png To prevent some trouble in the print process, make sure that you set the paper format. To do that, you select “Edit → “Current Drawing Preferences” and click on the “Paper” tab. Here you should set the “Paper Format” to the size of your paper for example A4.


To get more fancy prints, you should use the “Print Preview” button (or File → Print Preview). Here you can set the aspect ratio you would like and center the drawing to the page. Sometimes you want your drawing to be at a specific position. The position of your drawing on the page can be changed by clicking on the page (the white rectangle around your drawing) and moving it around.


Hint.png If your drawing has to be on an exact position you can draw a white (as printing white on white paper will make things disappear) rectangle, of the same size as your paper, around your drawing and selecting “Fit to page” in the “Print Preview”.

Saving

“File” → “Save as” will do the job, if you want to save to the dxf format.


Hint.png

Make sure that the “Files of type:” drop down says dxf and not something else. (Some people reporter that older versions of LibreCAD would choose a different format)


If you want to show off your work to someone, who only can view .bmp files, don't worry there is also a way to save your drawing to a .bmp image. “File → “Export” will do the trick.


Hint.png Besides the .bmp format and other raster formats you can save your image in the .svg format for better quality. (if the size of the svg drawing has to be precise look at this svg workaround)

Short-cuts/hot-keys

Some important short cuts:

  • Ctrl+N: Create new file
  • Ctrl+O: Open a file
  • Ctrl+S: Save your drawing
  • Ctrl+M or Space: Set the focus/mouse cursor to the input line of the command line
  • Ctrl+A: Select all/everything
  • Ctrl+K: Deselect all/everything
  • Esc: go back to previous action/end the drawing process
  • Double-Click the middle mouse button (scroll wheel) to auto zoom

Troubleshooting

“My drawing had some hatches but now I can't see them any more.”
Turn off the draft mode. “View” → “Draft”
“I can move my cursor only horizontally/vertically.”
Turn off “Restrict Horizontal” or “Restrict Vertical”.
“Snap” → “Restrict Horizontal” or “Snap” → “Restrict Vertical”
“In the Print Preview there is no “Fit to Page” button.”
Uncheck the “fixed” check box.
“I clicked on the “Print Preview“ button but how can I leave the print preview mode without printing?”
Turn off “Print Preview” mode. Hit the “Print Preview” button or uncheck “File” → “Print Preview”.
“While working on my drawing I can't find some changes I made to the drawing?”
Make sure the layer, where you applied the changes, is set to visible.
“I screwed up my file by saving an empty drawing over it, what can I do?”
There is a chance that In the directory where your file was saved. there is a file starting with “#”, for example “#myfile.dxf”. Just duplicate this file (copy & paste) and rename it as you like.
“I was told to use a command I can't find in the CAD toolbar.”
This command may be implemented as a plugin and be only available in the main menu.
“I miss a feature in LibreCAD, what to do now?”
Go to the LibreCAD forum and tell.
“I missed a feature in LibreCAD and just implemented it, what to do now?”
Go to the LibreCAD forum and tell.
“I have an issue which neither is listed in this list nor can be found in this manual.”
Go to the LibreCAD forum and tell.

Further information

http://wiki.librecad.org/index.php/LibreCAD_version_2,_users_Manual/Guide_-_by_Bob_Woltz

http://wiki.librecad.org/index.php/LibreCAD_Quick_Start_Guide

http://wiki.librecad.org/index.php/Commands

http://wiki.librecad.org/index.php/A_short_manual_for_use_from_the_command_line

There are also some videos about LibreCAD.

http://www.youtube.com/results?search_query=librecad&oq=librecad

for example: http://www.youtube.com/watch?v=53DOEKzL2rw&list=PLB9CB29692D89976A

Tutorials/manuals can be found on the forum of LibreCAD.

http://forum.librecad.org/Tutorials-Manual-topics-f5707542.html

http://forum.librecad.org/Tips-n-Tricks-f5531031.html